Content not accessible
Incident Report for thecallcenterschool
Resolved
We restored almost all of the lost modules. Unfortunately, some modules could not be recovered. The few customers affected by the data loss will be contacted individually.

Losing data is unacceptable. To ensure this does not happen again we're working on multiple improvements to our operations & recovery procedures. Again, please accept our apologies for any inconvenience caused.
Posted Mar 28, 2017 - 15:23 UTC
Identified
We have identified the root cause of the outage. It was caused by an accidental removal of all modules. We are currently restoring the deleted data.
Posted Mar 28, 2017 - 14:53 UTC
Investigating
Please be advised that we are currently experiencing an outage. We are working to resolve this issue as quickly as possible.

In the meantime, please accept our apologies for any inconvenience caused. We will let you know of any updates as soon as we can,

Thank you for your patience.
Posted Mar 28, 2017 - 13:03 UTC